Minor error/s

Posted in

#276 by jazz957
2018-09-08 at 17:29
Is it just me or is linking broken? I tried to make links on a producer page, to other producers, and the links don't seem to get created.

Edit: I guess it works better when I put it in the description box instead of the alias box. lolLast modified on 2018-09-08 at 17:31
#277 by leery
2018-10-28 at 19:00
The Prev/Next buttons for the screenshot viewer now disregard NSFW-ness. It always cycles through all images.
#278 by yorhel
2018-10-28 at 19:06
Ouch, you're right. I've temporarily rolled back the last two commits to fix that.

EDIT: There we go, this ought to fix it properly.Last modified on 2018-10-28 at 19:18
#279 by gregory
2018-11-11 at 13:29
link
I can't upload links on mobile without getting a "invalid url" error. I can upload the same link without a problem on my computer though.
#280 by wakaranai
2018-11-11 at 13:51
^ trailing slash '/' is required in URLs t2520.179
#281 by eacil
2018-12-06 at 09:54
When selecting a trait/tag, then clicking another tab, when you come back the trait/tag disappeared. The trait/tag is still active but hidden and it comes back after you launched the search and look at the filters again (and is properly displayed after that).
#282 by yorhel
2018-12-06 at 10:25
@281: Fixed.
#283 by warfoki
2019-10-02 at 13:56
Hah! Found the bug report thread! God, this was buried deep...

Anyway, I'm not sure if this is a bug or intentional, but some anime adaptations have a "hash" line after them for some reason: link

Not sure if that actually should be there or not.

------------------

On another note, I get this error message when trying to merge Mind Control and Hypnotism:

500 - Extraterrestrial Server Error

Ouch! Something went wrong on the server. Perhaps a misconfiguration, perhaps a bug, or perhaps just a temporary issue caused by regular maintenance or maybe even alien interference. Details of this error have been written to a log file. If the issue persists, please contact the site admin to let them know that they might have some fixing to do.
Last modified on 2019-10-02 at 14:25
#284 by yorhel
2019-10-02 at 14:38
Hah. You can see I'm actively developing again when there's tons of weird bugs to find.

On the tag merging: The problem is the tag-to-be-deleted should not have any child tags anymore.

Mind Control has Tentacle Body (Corruption) and Parasite - Symbiote
Hypnotism has Sex Involving Hypnosis

I need to fix that error message or, better yet, automatically move the child tags upon merge. But for now a manual move ought to work. This is a general problem with features that are rarely used: they don't get much testing. :P

EDIT: HASH thing fixed. Evidently I need to tone it down on the drugs.Last modified on 2019-10-02 at 14:45
#285 by warfoki
2019-10-02 at 14:49
I figured that it would be a child tag issue, that's why I removed Mind Control from under Hypnotism, but apparently it was the problem of Mind Control having child tags of its own, which I had no way of knowing, since deleted tags don't show up there (understandably).

Thanks for the info, it worked now!Last modified on 2019-10-02 at 14:51
#286 by warfoki
2019-10-03 at 21:37
Oh, hey another minor error popped up. If I go to my profile, on the discussion tab there's a number in brackets representing the number of discussions on my board. This one changes depending on whether I have that tab active or not:

when any other tab is selected VS when the Discussion tab is selectedLast modified on 2019-10-03 at 21:37
#287 by fuukanou
2019-10-03 at 22:10
The my account page (edit tab) appears to be borked for me, appearing totally blank. There's the tabs at the top and then immediately below it is the quotes and footer.
#288 by beliar
2019-10-03 at 22:19
Same for me.
#289 by yorhel
2019-10-04 at 05:24
This one changes depending on whether I have that tab active or not
Fixed. I made a slight improvement in the new code so private threads aren't included but forgot to adjust the old code (that's still being used for now).

The my account page (edit tab) appears to be borked for me, appearing totally blank.
Ah crap. This falls under the "works for me" category. Does a full refresh (Shift+F5) work? Can you open the login form in a private browsing tab and see if it's the same? Which browser are you using? Are there any errors in the browser console?Last modified on 2019-10-04 at 05:48
#290 by shining17
2019-10-04 at 05:54
Worked fine on my side.
#291 by beliar
2019-10-04 at 14:47
Did a full refresh and now it works. *shrug*

P.S. It's Ctrl+F5, not Shift+F5. :-)
#292 by yorhel
2019-10-04 at 14:58
Cool, glad that was it, would have been a nightmare to debug if it wasn't. While looking into this I noticed that I had forgotten to implement a force-browser-refresh-after-pushing-an-update. I've fixed that now, so the Shift-Control-CapsLock-F5 shouldn't be necessary anymore for future updates.
#293 by fuukanou
2019-10-04 at 15:13
I opened up the page again the normal way (no refreshing or anything) and it magically started working again. Might have just been some passing bug.
#294 by eacil
2019-10-07 at 09:48
nevermindLast modified on 2019-10-07 at 09:51
#295 by hshe
2019-10-09 at 16:47
Idk if this counts as an error, but is it possible to add exanple images to traits after the trait has been made?
#296 by beliar
2019-10-09 at 16:56
That's not an error. You cannot update the traits or tags after submission. Only a moderator can do that.
#297 by hshe
2019-10-10 at 12:33
Oh okay, thanks
#298 by hshe
2019-10-10 at 12:37
Is there anyway to ask a mod to update a trait or tag?
#299 by eacil
2019-10-10 at 12:41
Tag and trait threads for you to make your case.Last modified on 2019-10-10 at 12:41
#300 by rampaa
2019-10-13 at 20:11
@Yorhel, please have a look at link

Basically, Unicode sucks. In order to render CJK characters correctly, different fonts should be used. So, for example, the character 直 should look different on Siwang Zhibo Jian's and Imouto Chu☆ #01 Sunao Imouto no Shou's titles.

In Siwang Zhibo Jian's case, it should look like this: link
In Imouto Chu☆ #01 Sunao Imouto no Shou's case, it should look like this: link

As is, Firefox shows all the titles in Japanese way. Chrome, on the other hand, shows everything in Chinese way.

Reply

You must be logged in to reply to this thread.